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IMPORTANT

Adobe announced on March#, !"I# that it will no
longer develop or support Brackets starting September
#, 1"l

Adobe suggests that users move to Visual Studio Code,
which | second

For info about VSCode, see www.granneman.com/all-
presentations for slides


https://www.granneman.com/presentations/all-presentations
https://www.granneman.com/presentations/all-presentations

lnstallation



Windows, macOS,
& LInux



Brackets 1s available for download at brackets.io


http://brackets.io

1 Brackets Contribute APl Docs Blog Support

A modern, open source text editor that
understands web design.

Download Brackets 1.7 CI |Ck th |S

Other Downloads

& index.html| — Brackets
Working Files <div id="hero-wrapper">
<div 1id="hero" class="row">
<div class="large-12 columns'>
<hl>Brackets 1is an open source code editor for web designers and front-end developers. <a class='"noh
<div id="download">
<a id="hero-cta-button" href="https://github.com/adobe/brackets/releases/latest" class="large rd

iIndex.html

brackets.io | larz/vl v |

.gitignore X brackets.io.css: 378 | NewRule ¥

404.html
#hero-cta-button {

font: 400 18px source-sans-pro, sans-serif;
CNAME text-align: center;

padding-left: 1.5em;

padding-right: 1.5em;

blog.html

contribute.html

CSS






A Ple named something like
Brackets.Release.1.7.dmg will download

Double-click on the DMG Installer & a small window
should open



Brackets Release 1.7

2 items

Brackets.app

Brackets Release 1.7

Drag Brackets into the Applications folder



] WebSanity Share
® [ Inbox

- Click ! to eject (or right-click on
' ‘the name & select Eject)

=] BOOTCAMP

Q Remote Disc

U Brackets Releas... = a0

After Brackets Pnishes copying, eject the DMG installer



Toss the DMG Installer into the Trash (select the Ple &
press"# )







A Ple named something like
Brackets.Release.1.7.msi will download

Double-click on the MSI Iinstaller



Click Run
Click Next & then Install

If youOre asked if you want to Oallow the following
program to install software on this computerQO, click Yes

Click Finish



Toss the MSI Installer into the Recycle Bin



Portable Brackets



How Brackets
Works




Open Brackets



) Index.html (Getting Started) — Brackets

Getting Started <IDOCTYPE html>
<html>

index.html

main.css

<head>

S - <meta charset="utf-8'">

Y ajelicisiseliopiz | | | <meta http-equiv="X-UA-Compatible"
content="IE=edge">

<title>GETTING STARTED WITH BRACKETS</title>
<meta name="description" content="An
interactive getting started guide for

Brackets.">
9 | | <link rel="stylesheet" href="main.css'">
10 | | </head>
11V | | <body>
12 | | | |
13 | | | | <h1>GETTING STARTED WITH BRACKETS</h1l>
14 | | | | <h2>This 1is your guide!</h2>
i fls
167 | ||| <l
17 | | | MADE WITH <3 AND JAVASCRIP

11 M

Line 10, Column 12 Li INS HTML ¥ Spaces: 2



First
Extensions




HTML Templates,
Updated



o0 index.html (selectors) — Brackets

Naraag Elles 1 <!doctype html>
index.html 27 <html ]-ang="en">
3 <head>
4 <meta charset="UTF-8">
5 <title>CSS Selectors</title>
6 <link rel="stylesheet" href="styles/main.css'">
7 </head>
@ abelincoln.gif 8 <body>
index.htm| 9
styles 10 <hl>We’r| aaiable Themes Installed Default i
main.css 11
12 <div 1id=
13 < p> HTML Templates, Updated nserts HTML from a pre-made list of templates.
14 On t '
1S < / p> 1 265
16 <ol> - _
17 B
18 1 - |
19 <Li>
2O </01> Brackets Link File New: jsDelivr API 2. Easily link your files (PHP,
21 </div> JavaScript, CSS, images, audio, video, fonts) into the
22 O el b e
23 <p>
24 Lorem ~ nec quis diam placerat, laoreet lacus
BN | Drag zip here or Install from UR 2. tur blandit, sem nec congue rutrum,
risus UTTEULa ULTrICTES TUrpTS, €u VvenenatTs auT nTst-a aotor. Etiam molestie commodo dolor 1d
facilisis. Nullam id diam ex. Pellentesque pellentesque quam nisl, ac aliquam metus commodo
quis. Morbi egestas aliquet felis dignissim mattis. Vivamus augue libero, ultricies ut blandit
non, bibendum sed eros.
25 </p>
26
27 <p>
28 Lorem ipsum <strong>dolor sit amet</strong>, consectetur adipiscing elit. Donec quis diam

Line 2, Column 15 1 Errors: 14 INS UTF-8 = HTML » (’f} Spaces: 2



0 This repository Pull requests Issues Marketplace Explore +~- -

¥ rsgranne / Brackets-HTML-Templates-Updated ®Unwatch~ 1  Star 2  YFork 49
forked from talmand/Brackets-HTML-Templates
<> Code Issues 0O Pull requests 0 Projects 0 Wiki Insights Settings
Brackets extension that provides basic HTML templates of various doctypes. Edit
Add topics
0 89 commits ¥ 1 branch O 2 releases 42 9 contributors

Branch: master » New pull request Create new file @ Upload files @ Find file Clone or download ¥

This branch is 24 commits ahead of talmand:master. 11 Pull request Compare

] rsgranne Updated version number to 1.3.6 Latest commit 3c844d8 27 days ago

B html Updated links to framework templates & added versions 28 days ago
B nis Updated strings 6 months ago
=) README.md Added more info re updates & additions to templates, & footnote re Sk... 28 days ago
=) main.js Updated for new template filenames 27 days ago
=] package.json Updated version number to 1.3.6 27 days ago
=) strings.js Implemented localization strings and updated modal to dialog system. 4 years ago

EE README.md




After installation, go to Edit > HTML TemplateskE



iIndex.html

iIndex.html

index.html (test) — Brackets

HTML Templates

Choose a template...

Standard doctypes
Choose...

Framework templates

These templates are based on HTML provided with the framework, so some adjustments will be

necessary.

Choose...

Cancel

Line 1, Column1 — 1 Line

INS

UTF-8 ¥

Spaces: 2




e index.html (test) — Brackets

S ,)\ { ™ "I : YT s ™
Working Files

index.html

test

HTML Templates

index.html

Choose a template...

Standard doctypes

v Choose...

HTML4 Transitional
HTML4 Strict
XHTML 1 Transitional
XHTML 1 Strict
XHTML 1.1

ovided with the framework, so some adjustments will be

Cancel

Line 1, Column 1l —1 Line INS UTF-8 ¥ | Spaces: 2



Working Files

o index.html

test

index.html

O 00O ~NOOOUL A~ WDNBK

e
O Ul A WNRKROO

Line 1, Column 1

e index.html (test) — Brackets

k!doctype html>
<html lang="en">

<head>
<meta charset="UTF-8">
<title>Untitled Document</title>

<link rel="stylesheet" href="/css/main.css">

</head>

<body>

INS

UTF-8 ¥

HTML ¥

Spaces: 2



Indentator



index.html (Getting Started) — Brackets

1 <!DOCTYPE html>
27 <html>

§ N Y
{ | g ) NS
L i K W

Available Themes Installed

|O‘ indentator

NOTE: These extensions may come from different authors than Brackets itself. Extensions are not reviewed and have full local privileges.

Be cautious when installing extensions from an unknown source.
index

: Indentator
main
Andrew Huth

Re-indent a document using your current indentation

settings.

Install
1.0.3 —05/12/2014

More info...

< /title>

quick-edit h

Drag .zip here or Install from URL...

17 MADE WITH <3 AND JAVASCRIPT

-1 M

Line 13, Column 46 — 208 Lines

INS HIML ¥ /)  Spaces: 2



After Installation, go to Edit > Indent Document
Better yet, use the key commands!

E macOS: " $i
E Windows: Ctrl+Alt+]

Do not use Edit > Indent, as that just indents #line!



Working Files

index.html
test.html

Getting Started

index.html
main.css
screenshots

ladl quick-edit.png
test.html

O 00O NOOUL A~ WDN K

==
N = ®

13
14
IS
16

Line 14, Column 3

o test.html (Getting Started) — Brackets

<!doctype html>
<html>
<head>
<meta charset="UTF-8">
<title>Test Document</title>
</head>

<body> Before running the IndentatorE

<hl>Test Title</hl>

<p>

Lorem ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua. Ut enim ad minim
veniam, quis nostrud exercitation ullamco laboris
nisi ut aliquip ex ea commodo consequat.

<p>
Duis aute 1rure dolor 1n reprehenderit 1n

B [ IR S I | - =L e By R = [ = S o S-S = =g

INS HTML ¥ Spaces: 2



) o test.html (Getting Started) — Brackets

Working Files <1doctype html>

<html>
<head>
<meta charset="UTF-8">
<title>Test Document</title>
</head>

<body> After running the IndentatorE

index.html
test.html

Getting Started

index.html

main.css

O 00O NOOUL A~ WDN K

<hl>Test Title</hl>

screenshots

—
O

ladl quick-edit.png
test.html

—&
—

<p>
Lorem 1psum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

13 </p>

14

i B

€ r~ s - - e e i D i e R T Clg

i
N

Line 14, Column 1 INS HTML ¥ Spaces: 2



Run the Indentator after every few lines of code



Nu Markup Checker



test — Brackets

+ | | |= | Last Updated | I . nu markup
Available Themes Installed Default

NOTE: These extensions may come from different authors than Brackets itself. Extensions are not reviewed and have full local privileges.

3e cautious when installing extensions from an unknown source.

Nu Markup Checker for Brackets Adds Nu Markup Checker support to Brackts.
Takeshi Kurosawa More info...

0.1.1 — 08/18/2014

1 6049

Drag .zip here or Install from URL...




Nu Markup Checker runs every time you save



) o test.html (Getting Started) — Brackets

Working Files
<hl>Test Title</hl>

index.html

test.html
<p>

<p>
Getting Started Lorem “ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco lalioris nisi ut aliquip ex ea commodo

index.html
main.css

screenshots

ladl quick-edit.png

B
sestinusl e 7 Not correct HTML?
</p> Press Savek

<p>
Duis aute 1rure dolor 1n reprehenderit 1n voluptate
velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident,
sunt 1n culpa qui officia deserunt mollit anim 1d

est laborum.

1Q ¢ I'n>
Line 14, Column 9 INS HTML ¥ Spaces: 2




) test.html| (Getting Started) — Brackets

Working Files
<hl>Test Title</hl>

index.html

test.html
<p>

<p>
Getting Started Lorem +ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.
</p>
</p>

index.html
main.css
screenshots

ladl quick-edit.png
test.html

Error! Now click on itE

<p>
Duis aute 1rure dolor 1n reprehenderit 1n voluptate
velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident,
sunt 1n culpa qui officia deserunt mollit animiid

est laborum.

1Q ¢ I'n>
Line 14, Column 9 INS HTML ¥ Spaces: 2




Working Files

index.html
test.html

Getting Started

index.html
main.css
screenshots

ladl quick-edit.png
test.html

test.html (Getting Started) — Brackets

<hl>Test Title</hl>

<p>

<p>
Lorem 1psum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

14 </p> Line #' IS where the error

» S manifests itself

1 Nu Markup Checker Problem

15 No “p” elementin scope but a “p” end tag seen. </p>

WO%_ error messages are
written in OhumanishO

Line 14, Column 9 INS HTML ¥ Spaces: 2



) test.html| (Getting Started) — Brackets

Working Files

<!doctype html>
<html>
<head>
<meta charset="UTF-8">
<title>Test Document</title>
</head>
<body>

index.html
test.html

Getting Started

index.html

main.css

O 00O NOOUL A~ WDN K

<hl>Test Title</hl>

screenshots

—
O

ladl quick-edit.png
test.html

—&
—

<p>
Lorem 1psum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

13 </p> :
. Fixed!
1.5

€ r~ s - - e e i D i e R T Clg

i
N

Line 14, Column 1 INS HTML ¥ Spaces: 2



< & 8 temp.htm — Brackets

Working Files </div>

chartreuse-05.htm <footer>

index-02.htm <div class="container">
tertiary-01.htm <span class="copyright">
<img alt="Invertocat"
src="https://d2dfho4r6t7asi.cloudfront.net/assets/invertocat-
£10d7398407Fff679b054b8c4c86aa639.svg" />
charis.htm 143 <div class="copyright-text">Copyright &copy; 2014 <a
chartreuse-01.htm href="http://github.com">GitHub</a> Inc.
chartreuse-02.htm 144 <div class="crumb">All slide content and descriptions are owned by
chartreuse-03.htm creators.</div>
145 </div>
146 </span>
147
148 <ul class="1links">
149 <li><a href="/fag">F.A.Q.</a></1i>
L2 A2 i 150 <li><a href="/tos">Terms of Service</a></11>
temp.htm 151 <li><a href="/privacy">Privacy Policy</a></li>
tertiary-01.htm 152 </ul>
videos 153 </div>

colors-site-wu

chartreuse-04.htm
chartreuse-05.htm
Images

index-01.htm

10 Nu Markup Checker Problems X
11 Badvalueoctolytics-script-host forattribute name on element meta: Keyword octolytics-script-hostis not registered. <meta name="octolytics-af

25 Badvalue octolytics-dimension-user_id for attribute name on element meta: Keyword octolytics-dimension-user_id is not registered. <meta name="octolytics-di
25 Badvalue octolytics-dimension-user_username for attribute name on element meta: Keyword octolytics-dimension-user_usernameis notregistered. <metaname="octolytics-di
Elementdiv notallowed as child of element span in this context. (Suppressing further errors from this subtree.) <div class="copyright-text"
Considerusingthe hlelementasatop-levelheadingonly (allhl elements are treated as top-level headings by many screen readers and othertools). <h1>Talks by Bram Stein</

Considerusingthe hlelementasatop-levelheadingonly (allhl elements are treated as top-level headings by many screen readers and othertools). <h1>Speaker Details</h1>

Line 143, Column 1 INS HTML ¥ Spaces: 2



() iIndex.html (portfolio-sat) — Brackets
<p class="1tem-1ntro text-

muted">Learn the Linux command Lline!
agency.less </p>
lelclriand <iframe width="560" height="315"
src="https://www.youtube.com/embed/ns
BH_wgn-Bo"| frameborder="0"
allowfullscreen></1iframe>

= | | | | | <div class="text-left">
font-awesome < p>

Working Files

portfolio-sat

fonts Use this area to describe your
img project. Lorem 1ipsum dolor sit
index.html amet, consectetur adipisicing
js elit. Est blanditiis dolorem

() LICENSE culpa 1ncidunt minus dignissimos

ma|l e e B TN B R R T e [ Y
1 Nu Markup Checker Problem x

README.md 455 The “frameborder” attribute on the “iframe” elementis obsolete. Use CSSinstead. <iframe width="560" height="315" src="https://www.youtube.com/embed/nsBH_w

Actually understandable!

Line 455, Column 113 — Selected 16 columns Errors: 2 INS HTML ¥ Spaces: 2



Duplicate Flles
& Folders



iIndex

main

quick-edit

index.html (Getting Started) — Brackets

1 <!DOCTYPE html>

27 <html>
+ B ]

Available Themes Installed

Brackets Sort Text

Ingo Richter

0.1.4 —06/25/2015

Brackets Tools
Yasin Kuyu

0.2.0 —01/31/2015

Duplicate Files & Folders
Torin Pascal

1.1.0 —11/09/2014

Brackets Backup
Joselito Evangelista

1.0.4 — 10/09/2014

Drag .zip here or Install from URL...

17

-
Line 13, Column 46 — 208 Lines

|O‘ duplicate

Sort Text extension for Brackets. Provide operations to sort,
reverse, randomize and remove duplicate lines.
More info...

Translated into 2 languages, including yours

Brackets developer tools extension
More info...

Translated into 8 languages, including yours

Duplicate, copy, and move files and folders in the project
view.
More info...

File Backup Extension for Brackets. This extension will
create a backup copy (.bak) of the active file in its current
directory.

More info...

MADE WITH <3 AND JAVASCRIPT

Install

Install

Install

I
18

11>

INS

;S">

HTML ¥

< /title>

A

Spaces: 2



Right-click on a Ple (or folder) & select Duplicate

Note that this does not work for Ples under Working
Files



) test.html| (Getting Started) — Brackets

<!doctype html>
<html>
<head>
<meta charset="UTF-8">
<title>Test Document</title>
</head>
<body>

Getting Started

index.html

main.css

screenshots
ladl quick-edit.png
test.html

O 00O NOOUL A~ WDN K

<hl>Test Title</h1l>

= =
O,

<p>
Lorem 1psum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

13 </p>

14

i B

i
N

€ r~ s - - S M= = Ity Bt i e i e R S Eg s

Line 1, Column 1 INS HTML ¥ Spaces: 2




) test.html (Getting Started) — Brackets

Getting Started ‘< ldoctype html>

<html>

index.html
<head>

main.css

<meta charset="UTF-8">
<title>Test Document</title>
</head>
<body>

screenshots
ladl quick-edit.png
test.htyg

New File
New Folder

O 0o ~NOOUlL A~ WDNBK

Rename

<hl>Test Title</hl>

Delete

—
O

Show in Finder

—
f—2

Find in...

Replacein...

<p>
Lorem ipsum dolor sit amet, consectetur
Eiii“me adipisicing elit, sed do eiusmod tempor
Mark incididunt ut labore et dolore magna aliqua. Ut
ﬁszii enim ad minim veniam, quis nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.
13 </p>
14

15V | | <p>

€ ~ o G S R E s S JPECaE AR 4T SR A RS [ A P 85 SRR

Line 1, Column 1 1 INS HTML ¥ Spaces: 2

-
N




) test.html| (Getting Started) — Brackets

Getting Started ‘< ldoctype html>

<html>
<head>
<meta charset="UTF-8">
<title>Test Document</title>
</head>
<body>

index.html

main.css

screenshots

ladl quick-edit.png

test copy.htm| effsmssave

test.html

O 00O NOOUL A~ WDN K

<hl>Test Title</hl>

= =
O,

<p>
Lorem 1psum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

13 </p>

14

i B

€ r~ s - - S M= = Ity Bt i e i e R S Eg s

i
N

Line 1, Column 1 INS HTML ¥ Spaces: 2



o test copy.html (Getting Started) — Brackets

<!doctype html>
<html>
<head>
<meta charset="UTF-8">
<title>Test Document</title>
</head>
<body>

Getting Started

index.html

main.css

screenshots
ladl quick-edit.png
test copy.hig

New File

test.html

New Folder

O 0o ~NOOUL A~ WDN B

T
N

Rename

<hl>Test Title</hl>

Delete

—
O

Show in Finder

—
f—2

Find in...
Replacein...

<p>
Lorem 1psum dolor sit amet, consectetur
- adipisicing elit, sed do eiusmod tempor
Mark incididunt ut labore et dolore magna aliqua. Ut
Hoveto fere enim ad minim veniam, quis nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.
13 </p>
14
15V | | <p>

- P~ e D SR S e N2 < (A . . S Bl ==l PR =N [ 14 S

Line 1, Column 1 INS HTML ¥ Spaces: 2

=
N

Refresh File Tree

Copy to Here




Debugging




Brackets provides ( ways to debug your code

#. Colors

. Nu Markup Checker
% Indentator

(. Live Preview



Colors



) test.html| (Getting Started) — Brackets

Working Files
<hl>Test Title</hl>

index.html
test.html

<p>
o <p>
Getting Started Lorem 1psum dolor sit amet, consectetur

adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

</p>

</p> If you see red,

- thereOs a problem

Duis aute 1rure dolor 1n reprehenderit 1n voluptate
velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident,
sunt 1n culpa qui officia deserunt mollit anim 1d

est laborum.

1Q ¢ I'n>
Line 14, Column 9 INS HTML ¥ Spaces: 2

index.html
main.css
screenshots

ladl quick-edit.png
test.html




Nu Markup Checker



) test.html| (Getting Started) — Brackets

Working Files

<hl>Test Title</hl>

index.html

test.html
<p>

<p>
Getting Started Lorem +ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

zjgi If you see an error symbol,
thereOs a problem

index.html
main.css
screenshots

ladl quick-edit.png
test.html

<p>
Duis aute 1rure dolor 1n reprehenderit 1n “%oluptate
velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proiderit,
sunt 1n culpa qui officia deserunt mollit anim 1d

est laborum.

1Q ¢ I'n>
Line 14, Column 9 INS HTML ¥ Spaces: 2




Indentator



) test.html| (Getting Started) — Brackets

Working Files

<hl>Test Title</hl>

index.html

test.html
<p>

<p>
Getting Started Lorem +ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor
incididunt ut labore et dolore magna aliqua. Ut
enim ad minim veniam, quils nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo
consequat.

A If your indentation is screwy,
thereOs a problem

index.html
main.css
screenshots

ladl quick-edit.png
test.html

<p>
Duis aute 1rure dolor 1n reprehenderit 1n voluptate
velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident,
sunt 1n culpa qui officia deserunt mollit anim 1d

est laborum.

1Q ¢ I'n>
Line 14, Column 9 INS HTML ¥ Spaces: 2




LIve Preview



If things donOt look right, thereOs a problem




ConbPguration



Spaces or Tabs?



A debate has raged for decades: spaces or tabs?

Tabs allow di) erent users to indent at the size they like,
but can cause problems

Spaces are spaces are spaces N the same for everyohe
but can cause problems

Pick the one you like (I like spaces)









How many spaces? Or, If tabs, how big are they?
L, (,or*?

* & ( seem too big to me & create nesting that Is too
deep, so | always choosé









Themes



Click on View > ThemesE



You can change the theme

Adjust so
you can
read your
code (try
#3, | use

I( for Source Code Pro Is a great default
teaching)




Two themes are installed by default

YOou can
Install
other
themes too



Common Themes



Certain themes appear in almost any editor that
supports theming

E Monokal
E Soda
E Solarized



You should check those theme out tpst

E They probably will meet your needs
E If you switch to a di) erent editor, you can keep using
your theme



Solarized

Originally developed Iin "#" (for Vim?)






How many
themes get
articles
written
about them?












Soda

Originally developed for Sublime Text (In !"## ?)












Monokal
Originally developed for TextMate in !""$

Many variants, some combined with Soda









Monokal Darker Soda



Installing Themes



Extension Manager > ThemesE



Like 1t? Click Install



Click on More infoE to see a preview of the theme






LetOs try another oneE









| donOt like it, but | can preview it



Other
Extensions
















Thank you!

scott@granneman.com
www.granneman.com
ChainsawOnATIireSwing.com
@scottgranneman

jJans@websanity.com
websanity.com
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Changelog

"% -"00-1& #! . Added notice that Adobe will no longer
support Brackets & suggests moving to Visual Studio
Code

"#+ -##"# #.4 Switched theme to Granneman #( ;
minor formatting Pxes; corrected info re: Pnding
themes; changed subtitle

I"#+ -#"-000#" : FIrst release
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